• January 28, 2019 at 9:33 am #15221
    girgin2008
    Participant

    Hi,
    I am just building my drone with Pixhawk 2.4.8 – first time I connected telemetry cable, I realized it is getting extremely hot and I disconnected it immediately.

    here is how I connected,

    Pixhawk port serial 4/5 -> mlvss -> FrSky R9 receiver -> RC in on Pixhawk.

    I am suspecting it could be my fault because I’ve connected Lipo connector incorrectly first time to mlvss and disconnected immediately, but perhaps it was too late and it burned pixhawk too?

    anyway, I just want to make sure, I am not skipping a step that I should be doing,, if you guys think cable is gone, i will order a new set.

    January 28, 2019 at 11:15 am #15227
    Thomas Lauzon
    Keymaster

    Hello, make sure you only plug the cable when the Pixhawk is off. If it happens again when you turn on the Pixhawk after the cable has been plugged in, we’ll send you a replacement. Best,
    Thomas
    CT

    January 28, 2019 at 2:05 pm #15228
    girgin2008
    Participant

    Thanks CT, will test it out as soon as possible and let you know.

    Eg

    January 28, 2019 at 8:38 pm #15253
    girgin2008
    Participant

    Hi Thomas, tested again and no change ,it takes 30 seconds then it gets crazy hot. Will order new one tomorrow, thanks a lot.

    Eren

    February 4, 2019 at 12:20 pm #15517
    girgin2008
    Participant

    Hi CT,
    I got a new pixhwak controller and although the new cable is on its way, I wanted to test it if the telemetry cable will heat it up again. The same thing happened, after 30 seconds or so, it got crazy hot so I removed it.

    I also need a clarification of the direction of the connector, it can be connected both ways due to your connector has a clip at its end, instead of the straight type that cant be plugged in an incorrect way.

    I am assuming, when you take the pixhawk, direction looking forward; the end of the connector which has the red cable will be always on the left…

    thanks,
    Eren

    February 4, 2019 at 12:51 pm #15518
    Florent Martel
    Keymaster

    Hi Eren,

    If the cable is damaged, we strongly advise that you destroy it or return it to us.

    There is really only one way in which the telemetry cable should fit into the serial port of the Pixhawk or Pixhawk 2.

    Please not though that the Pixhawk 2.4.8 is a Pixhawk 1 and not a Pixhawk 2. v2.4.8 refers to the version of the board of the Pixhawk 1. This is very confusing the way it was done…

    The Pixhawk 2 (aka “The Cube”) is a different flight controller altogether, with different connectors than the Pixhawk 1 with v2.4.8 board. The telemetry cables you’ve purchased are for the Pixhawk 2 (aka “The Cube”). Do not try to force a Pixhawk 2 telemetry cable onto the connectors of a Pixhawk 2.4.8. The connectors are not the same and are not compatible.

    If you want more comments, feel free to send your pictures and questions to: [email protected]

    February 4, 2019 at 1:42 pm #15519
    girgin2008
    Participant

    that means I made the same mistake twice 🙁
    I ordered the same cable second time so I have to return it and the original one and get the pixhawk 1 version of telemetry cable.

    is there a process somewhere how I can do it?

    thanks – Eren

    February 4, 2019 at 2:01 pm #15524
    Florent Martel
    Keymaster

    We’ve talked by email before, so we’ll just contact you with RMA instructions.

You must be logged in to reply to this topic.

Topic Tags