• June 7, 2019 at 9:57 am #20762
    chainbreaker2012
    Participant

    Hello, this is my first venture into the long range receivers and just got a new x9d se with the r9m module. My pixhawk is on the way and I want to be sure I know how to wire up the r9mm properly to it. I have done a few searches and I know about the inversion issues of the other taranis recievers. I see the r9mm has inverted already built in to it so I’m trying to figure out how I need to wire this up to my pixhawk. could someone please send me a simple drawing for this or something of that nature please.
    Thank you for your time!
    Thomas

    June 7, 2019 at 1:29 pm #20770
    Florent Martel
    Keymaster

    Hi Thomas,

    Besides power (V+, GND) and servo signals (SBUS), for telemetry specifically, it’s as simple as connecting the inverted SPort wire to the TX pin of the serial port you want to use on your flight controller, and then configure that port for half-duplex using the corresponding SERIAL#_OPTIONS parameter. So, set SERIAL2_OPTIONS to 2 if using “TELEM2” on a Pixhawk and wire the inverted SPort to TX which is pin 2, right next to the red wire, on a Pixhawk.
    http://ardupilot.org/copter/docs/parameters.html#serial2-options-telem2-options

    June 15, 2019 at 12:15 pm #21009
    chainbreaker2012
    Participant

    Awsome, Thank you very much!

    June 17, 2019 at 9:51 am #21038
    chainbreaker2012
    Participant

    Question what version or ardupilot are you working with? When I go to advanced parameters ans down to the serial options it only lets me select baud rate and what protocall to use. How can i find SERIAL2_OPTIONS? Thank you.

    June 17, 2019 at 12:14 pm #21061
    Florent Martel
    Keymaster

    Hi Thomas,

    Yes, I should have mentioned that the OPTIONS were added to the ArduPilot code base back in November, so you must use a fairly recent version of ArduPilot. I just checked and looks like the stable still does not have that parameter, so your best bet at this time is probably to use the “latest” firmware: http://firmware.ardupilot.org/Copter/latest/

    Baud rate does not need to be set since it’s hard-coded when the FrSky protocols are used. Set SERIAL2_PROTOCOL to 10 when using FrSky Native Passthrough (the protocol used by FlightDeck). Setting SERIAL2_PROTOCOL to 4 is also a viable option when you just want some basic telemetry without using a script such as FlightDeck on your Taranis.

    June 17, 2019 at 1:10 pm #21069
    chainbreaker2012
    Participant

    Fantastic, thank you again for the fast reply.

You must be logged in to reply to this topic.