• January 8, 2016 at 8:43 am #776
    Mfbs17

    I have already installed the the script ver.1.2 and would like to upgrade to ver2.0 . where I cand find the new script(ver2.0).
    The procedure for upgardeing is to merge/rewright the script.Is it so?
    Is there a limit in how many times a person can load the zipfile that you have enclosed by purchasing the cable?

    January 8, 2016 at 2:11 pm #780
    Florent Martel
    Keymaster

    Use the download link in your email or look at your order on your account online.

    To upgrade, yes, you would copy to the Taranis the content of the SDcard folder found in the zip file and replace any already existing file on the SD card of the Taranis.

    Migration to v2.0 of the scripts require that you also flash your Pixhawk.

    We have carefully thought through and decided in v2.0 to update the protocol to something that has expandability and greater benefits to the community while minimizing the need to update your firmware in the future.

    There is a download limit on the file, but you can contact us if you need to download it again. This mechanism help us monitor downloads.

    January 8, 2016 at 5:47 pm #785
    Mfbs17

    After flashing the pixhawk and copying the sdcard contents into Taranis the Display description is still showing the older ver. rather than new one.
    the other thing that I have noticed that when I connect the pixhawk to missionpalnner via usb and when I move the quad I can see the movement of the quad in missionplanner but not in Taranis telemetry dispaly and when I change the flightmod in Taranis nothing happends regardless of which flightmod you are in telemetry display?

    January 8, 2016 at 5:56 pm #786
    Florent Martel
    Keymaster

    If the Taranis display doesn’t show v2.0, then you have an older version. Use the download link in your email or look at your order on your account online to download the v2.0 of the scripts and copy them to your Taranis.

    It looks like you flashed your Pixhawk successfully. Just make sure you have v2.0 of the scripts on your Taranis and you should be good to go.

    January 8, 2016 at 5:58 pm #787
    Mfbs17

    When I turn the Taranis off and on while holding the quad and movig it around and than turn the Taranis On again I can see the movement for about 25/30 second and all of suddan it stop showing the movement and memorize the last flightmod .

    One thing I have forgot to mention that I have not caliberated the compass yet .I am not sure if that is the cause.

    January 8, 2016 at 6:05 pm #788
    Florent Martel
    Keymaster

    That is expected behavior (which I tested on my end) when your Pixhawk is up to date but have an older version of the scripts.

    January 9, 2016 at 2:25 am #791
    seaman55

    I’m running this on a Taranis X9E, and a Flamewheel F550 hexacopter. I’m running 2.1.7 on the Taranis, and have updated the files on the Taranis as instructed, and also flashed with the Hexa firmware from your GitHub link. I had to use QGroundControl to write the firmware as Mission Planner kept telling me it was the same version that was already installed on the Pixhawk. All of the battery voltages are reporting wrong as if the firmware is still the old version.

    Have the other firmware versions on GitHub been updated? I really suspect that the Hexa is still the original used for 2.1.6 or earlier.

    January 9, 2016 at 5:44 am #794
    Florent Martel
    Keymaster

    Another user uncovered and just made us aware on the forum that there are more significant changes in OpenTX 2.1.7 than originally thought and tested. We will update the scripts to comply with the changes in 2.1.7 and will notify everyone through a post of the forum when that is done. For now, you need to use OpenTX 2.1.6 for the user interface to work…

    I loaded the hexa firmware just to make sure, and it works. The firmwares for the different copter frames are all compiled automatically one after the other…

    January 19, 2016 at 2:30 pm #888
    Steven Brummett
    Participant

    After realizing you have an update to the script, I tried to download and got the following:

    Sorry, you have reached your download limit for this file Go to homepage

    Is there any way this can be sent to me?

    Thank you.

    January 19, 2016 at 8:19 pm #889
    Florent Martel
    Keymaster

    Hi Mark,

    I’ve reset your download counter so you can download the latest update. You can see how many downloads you have left by logging onto your account (since you have an account linked to your order). Please do not hesitate to request again if necessary.

You must be logged in to reply to this topic.