• January 15, 2016 at 12:48 am #867
    Joshua
    Participant

    Craft and Theory,

    I recently got the cable working with my Pixhawk and X6R, however the refresh rate on the telemetry page script is REALLY slow… Also sometimes messages come in garbled or half there….

    I checked the logs folder on the Taranis X9E SD Card, and it is empty. I know this can cause problems being full.

    Here are my firmware/settings:
    Pixhawk V3.3.3-rc1 (Quad) with Craft and Theory Modification
    X9E with opentx 2.1.7
    Telemetry script is v2.2
    The Model setup on the Taranis is set to D16, CH1-8.

    All 100X series telemetry messages +GPS message are ID 28.
    RSSI,RxBt, and SWR telemetry messages are ID 25.

    I’ve also noticed that if I leave the Taranis in telemetry discover mode for a long enough time, I start to pick up 100X series messages that are other than ID 28, such as ID 1,6. Not sure if this is related.

    Any ideas on how to get the update rate higher or fix some of these weird data outputs?

    January 15, 2016 at 10:18 am #868
    Thomas Lauzon
    Keymaster

    Hi Joshua, thanks for reaching out.
    It looks like your Pixhawk could be running slow. Could you check that your Pixhawk’s SD card is not full?

    January 15, 2016 at 10:29 am #869
    Thomas Lauzon
    Keymaster

    Also, try moving away from the receiver at least 5ft. The signal can be choppy if you are too close. You can also cover the antennas with your hand.
    Please let us know if these suggestions helped.

    January 15, 2016 at 11:31 am #870
    Joshua
    Participant

    Hi Thomas,

    The SD card is not full. Also covering both the RX antenna and the TX antennas did not help.

    The heartbeat for RSSI,RxBt, and SWR (native Frsky telemetry messages) are updating like normal on the Taranis telemetry page. The asterisk is flashing for those all the time, but the 100X series messages are flashing intermittently and infrequent.

    January 15, 2016 at 1:05 pm #871
    Joshua
    Participant

    I think I may have figured it out. I’ll put it here for others.

    I had to adjust the stream rates in the pixhawk firmware. Open Mission Planner -> Config/Tuning -> Full Param

    My USB stream rate (SR0) is the following:
    SR0_EXT_STAT = 5
    SR0_EXTRA1 = 2
    SR0_EXTRA2 = 2
    SR0_EXTRA3 = 0
    SR0_PARAMS = 10
    SR0_POSITION = 5
    SR0_RAW_CNTL = 0
    SR0_RAW_SENS = 0
    SR0_RC_CHAN = 0

    My Serial 4/5 stream rates (SR3) the following:
    SR3_EXT_STAT = 2
    SR3_EXTRA1 = 5
    SR3_EXTRA2 = 5
    SR3_EXTRA3 = 3
    SR3_PARAMS = 0
    SR3_POSITION = 0
    SR3_RAW_CNTL = 0
    SR3_RAW_SENS = 5
    SR3_RC_CHAN = 0

    Now I have super fast refresh on the Taranis telemetry screens.

    January 15, 2016 at 1:40 pm #873
    Thomas Lauzon
    Keymaster

    Hi Joshua,
    This is very interesting. We haven’t seen this before. Thanks for finding the error and solution. 🙂
    We would like to try to replicate the problem and understand why it happens so that we can include it in our user manual.
    Could you tell us what your SR0 and SR3 parameters were when you had the slow telemetry? Which port is your telemetry cable connected to?
    Thanks!

    PS: now that you have it up and running, how do you like the display interface? Any feedback/suggestion is appreciated.

    January 15, 2016 at 2:00 pm #876
    Joshua
    Participant

    Yes it was interesting. I also had other problems with my pixhawk like Compass Errors, and Bad Accelerator Errors.
    I found a suggestion from another forum that instructed me to flash ArduRover then flash back to Arducopter.
    This cleared up the errors above and may have fixed the telemetry as well.

    Before I did this I only tried to reflash ArduCopter 3.3.3 over and over and over.

    I don’t remember what the SR0 and SR3 numbers were before I modified them…. I don’t really remember changing them in the past, so they were probably default to start with.

    One of these two things made the difference.

    The display is pretty cool, def worth the cost. I don’t have to lug around a tablet or computer anymore to see what the pixhawk firmware is doing. I like the Mavlink message history and the GPS page/info. My only suggestion would be a scroll able history of MAVlink messages.

    Can’t wait to fly it.

    January 16, 2016 at 9:18 pm #883
    sheets.d

    I have a suggestion. The ability to customize the display would be fantastic. Not everybody uses battery values. GPS on the main screen would be great.

    January 21, 2016 at 1:46 pm #897
    Thomas Lauzon
    Keymaster

    Hi sheets.d. Thanks for the suggestion!

You must be logged in to reply to this topic.