• July 31, 2018 at 8:46 am #12890
    rge
    Participant

    I purchased your telemetry cable for PixHack and I cannot get the telemetry to link up. It is stuck on the ‘Waiting for your flight controller’.

    Looking at the pinouts, I believe there may be a problem. You have wires coming from pins 1,2 & 5,6.

    The pinout for the USART ports on the PixHack are: Gnd, +5v, Rx, Tx, CTS, RTS. So the Tx and Rx are not connected through the cable.

    July 31, 2018 at 10:03 am #12891
    Thomas Lauzon
    Keymaster

    Yes, the cable you ordered is for Pixhack v3. You will need to change the order of the pins in the housing to match the Pixhack v5 order, which is the one you mentioned.

    Pixhack v3 -> Pixhack v5
    ——————————-
    TX (1, red), -> (4)
    RX (2), -> (3)
    – (3),
    – (4),
    VCC (5), -> (2)
    GND (6) -> (1)

    Best,
    Thomas
    CT

    July 31, 2018 at 11:22 am #12892
    rge
    Participant

    Thank you – it is still not working – Any possibility the wrong pinout fried the board

    July 31, 2018 at 11:51 am #12893
    Thomas Lauzon
    Keymaster

    It’s possible. Let’s check a few things first. Please try to perform a discovery in OpenTX. See if GPS appears (with Flight Controller on first, and a GPS connected to it).
    Double-check that SERIALX_PROTOCOL is set to 10, where X is the port number your cable is attached and no other ports set to 4 or 10.

    July 31, 2018 at 1:20 pm #12894
    rge
    Participant

    It fried 2 of my USARTS on my brand new V5 flight controller!

    July 31, 2018 at 1:55 pm #12895
    Thomas Lauzon
    Keymaster

    Sorry to hear that. Could you provide more details? Please send us an email at [email protected] with your testing procedure and photos if relevant. We’ll try our best to help you with this.

    September 13, 2018 at 3:51 pm #13086
    rge
    Participant

    I am getting only about 7 telemetry parameters 2 of which I believe is from the FLVSS – Cels, RSSI, RxBt, VFAS, Alt, VSpd & GPS. Every few seconds, I get a sensor lost message followed by an addition of a GPS entry up to 25 entries with 20 duplicate GPS entries with different Instance IDs.

    Any help would be appreciated…

    September 13, 2018 at 4:22 pm #13088
    Florent Martel
    Keymaster

    Looks like this issue, that we were never given an opportunity to really resolve: https://github.com/ArduPilot/ardupilot/issues/4744

    The symptoms are typical of when the flight controller takes too long to respond to the polling requests from the FrSky receiver, resulting in responses to poll requests others than the one originally intended, which creates the duplicates you mentioned. That, combined with the sensor lost messages really show that the responses from the flight controller are significantly delayed. There are some details on how you may be able to resolve that in the troubleshooting section of the FlightDeck manual, including addressing the most common cause with is the flight controller SD card.

    If not already done, you may also want to update to the latest version of ArduPilot and possibly try the ChibiOS version which should be better at CPU and memory management.

    September 13, 2018 at 4:50 pm #13090
    rge
    Participant

    I am running the latest RC version of Ardupilot/ChiBios and running on a PixHack V5 with a FMU v5.

    September 18, 2018 at 10:19 am #13100
    rge
    Participant

    I just received my 2 brand new Telemetry cables and unfortunately am still having the same problem. I only get 8 telemetry sensors. Any idea what the problem could be or how to approach – Thank you.

    September 18, 2018 at 12:33 pm #13102
    Florent Martel
    Keymaster

    It is the expected result to get these additional discovered sensors once everything is connected and configured: VFAS, Alt, VSpd & GPS

    If you’re not experiencing intermittent connectivity issues with the telemetry but you’re still stuck on the splash screen, consider updating OpenTX to v2.2.1 or later. You can also send screenshots or a video of the problem to [email protected] so that we can better assist you.

    September 18, 2018 at 1:03 pm #13103
    rge
    Participant

    The telemetry screen comes up but, I used to get 21 sensors. Now, I only get 8. FrySky PassThru provides many more than a handful of sensors?

    September 18, 2018 at 3:34 pm #13104
    Florent Martel
    Keymaster

    The passthrough protocol in and of itself provides only one discoverable sensor: GPS.

    Which other would you like to have access to from the OpenTX environment?

    Please email us at [email protected] so we can futher assist you.

You must be logged in to reply to this topic.