• August 4, 2019 at 4:53 pm #22980
    jax200
    Participant

    Hi

    Would appreciate any help with updating a PH4 mini to the latest 3.6.10 firmware.
    Using Mission Planner, I have tried both the “normal” and the “custom” update modes.
    The error message is : “No response from board”.
    I am getting the musical tones during the process.

    references:
    https://discuss.ardupilot.org/t/pixhawk4-mini-holybro-failed-to-update-io-fw/37166

    August 7, 2019 at 1:15 pm #23138
    jax200
    Participant

    Was eventually successful, despite getting other errors along the way.

    Ref: https://discuss.ardupilot.org/t/copter-3-6-10-released/45367

    August 8, 2019 at 10:23 pm #23223
    Florent Martel
    Keymaster

    Thanks for sharing. Glad you got this resolved.

    January 27, 2020 at 12:32 pm #28832
    rochmesa
    Participant

    Hi..Instead of wiping all parameters, could you try perhaps loading master onto the board? This can be done by opening MP’s Install Firmware screen and then press Ctrl-Q. The version displayed below the multicopter icons should change to “3.7.0-dev”. If this works then I was wondering if you could then download a dataflash log and post it somewhere? You may need to set LOG_DISARMED = 1. If the vehicle is locking up on startup my guess is that it’s the independent watchdog that is being incorrectly triggered and a message will appear in the log written on the next startup after the lockup.

You must be logged in to reply to this topic.