• September 27, 2017 at 7:08 am #9315
    Petrica Bratu
    Participant

    Hello. I have been successfully using FlightDeckQ with the Internal XJT module and X8R receiver, connected to a Pixhawk 2.1 and two MLVSS sensors – no issues whatsoever. I have recently upgraded to the new long-range radio system – R9M and I would like to report that the following are missing from FlightDeckQ:
    – MLVSS info – I get no cell info although I can see the telemetry data in the Telemetry page of model setup
    – GPS info – no GPS info, neither in FlightDeckQ nor in model Telemetry page.

    Is anyone else having similar issues?

    Thanks!

    September 27, 2017 at 6:08 pm #9360
    Florent Martel
    Keymaster

    Hi Peter,

    Thanks for reporting this. This has been a topic of discussion over the last week between us and the OpenTX developers in an attempt to figure out the issue. The problem has been identified and is related to the R9 itself and not FlightDeck or OpenTX. It actually affects all sensors and you’ll notice that their output (frequency of updates) is really low on the R9. The issue has been forwarded to FrSky so that they can fix it. A firmware fix coming from FrSky should be expected fairly soon.

    We’ll also post a guide (blog) on our website within the next couple of weeks detailing how to update the firmware of FrSky sensors, TX modules (including internal modules of the Taranis), and receivers. The only equipment needed to perform a firmware update is the Taranis itself and the update can be completed in only a few steps…so it should be quite simple if you use our guide!

    November 3, 2017 at 4:49 pm #10268
    Florent Martel
    Keymaster

    Good news! FlightDeck now works on the FrSky R9 system which has a range of up to 6 miles!

    As mentioned in my previous post, we helped FrSky find and fix a bug in the firmware of the R9 system.

    All you have to do is update to the latest firmwares on both the R9 (RX) and R9M (TX module) to get telemetry to work correctly.

    R9 firmware: https://www.frsky-rc.com/wp-content/uploads/Downloads/Firmware/R9/FW-R9-171030.zip
    R9M firmware: https://www.frsky-rc.com/wp-content/uploads/Downloads/Firmware/R9M/FW-R9M-171030.zip

    To update the firmwares, follow this guide: http://www.craftandtheoryllc.com/fw-guide

    We’ll soon add the R9 system for sale in our store so that anyone can buy this incredible radio at a discount when bundled with a telemetry cable and FlightDeck.

    November 11, 2017 at 7:45 am #10415
    Stefan

    Thank you for the informations.

    With the aktual version FrSky provided a LBT-Version for Euorpa. But with this version the C&T Lua-Script is not working.

    Best regards,
    Stefan

    November 11, 2017 at 8:26 am #10416
    Stefan

    With the FCC Version I do not get text messages and it is not very stable at the moment.

    Best regards,
    Stefan

    November 11, 2017 at 2:19 pm #10419
    Florent Martel
    Keymaster

    Hi Stefan,

    I’ve tested the FCC version of the new R9/R9M firmwares successfully after working with FrSky on getting this fixed (R9_FCC_171030.frk/R9M_FCC_171030.frk). Everything gets through including text messages. The only reason I can think of for your issue with the FCC firmwares is that the TX and RX are too close to each other. When the signal is too strong, telemetry doesn’t go through or is at least spotty… You may also try rebinding…

    I just tested the LBT (EU) version (R9_LBT_171030.frk/R9M_LBT_171030.frk) and I confirm that telemetry does not work properly. Some data goes through and I’m able to get FlightDeck running, but some of the data is corrupted. I’ll have to look in more detail as to what is happening and let FrSky know about this.

    So, for now, FlightDeck works on the R9M/R9 system only with the FCC firmwares.

    November 12, 2017 at 4:00 am #10425
    Stefan

    Hi Florent,

    thank you for your Reply.
    I did another test and you are right – I had to increase the distance between TX and RX a lot and then Flightdeck is working in FCC mode.
    But with less distance between TX and RX Flightdeck crashes. So you have to optimize your code for corrupted data transmission.

    Waiting for a new LBT-Version…
    Best regards,
    Stefan

    November 12, 2017 at 11:30 pm #10431
    Florent Martel
    Keymaster

    Hi Stefan,

    The code has a number of routines to increase robustness and there’s a CRC for the data transmitted so we definitely have that in mind when coding.

    Did you test FlightDeck right after flashing the new firmwares? I’ve noticed there’s sometimes SD card access issues right after flashing an external device, so if that was the case, are you able to repeat the crash? if so, could you email [email protected] with details about the crash so we can try to replicate? I haven’t had that happen on my end yet…

    November 13, 2017 at 4:32 pm #10436
    Stefan

    Dear Florent,
    some minutes ago I have tried to make some videos for you with a X8R and the R9. The X8R works good and after changing to the R9 first the problems were gone. After some minutes the taranis EEPROM crashes completely and initializes the EEPROM new.
    Then I flashed the taranis with the N443 Firmware and reinstalled my models.
    Doing some tests after this and I can not replicate the crash of fligtdeck. I will do more tests the next days and inform you.

    Best regards,
    Stefan

    November 13, 2017 at 5:32 pm #10437
    Florent Martel
    Keymaster

    Thanks Stefan for your work on this. Good that you mention the version of OpenTX and are doing more tests. FlightDeck is currently meant for the “latest stable” 2.2.0 (2017-05-30). Where is N443?

    Keep me posted…

    November 14, 2017 at 6:59 am #10443
    Stefan

    http://downloads-22.open-tx.org/nightlies/companion/windows/
    http://downloads.open-tx.org/2.2/nightlies/sdcard/

    Hi Floren,
    please find the nightly builds in the links. Without these Firmwares you are not able to configure failsafe and the options of the R9 and R9M.

    Best regards,
    Stefan

    November 14, 2017 at 12:14 pm #10445
    Florent Martel
    Keymaster

    Thanks Stefan,

    With the beta 2.2.1 (N434) I tested, telemetry on the LBT (171030) still does not work correctly….

    Options for the R9 in OpenTX are RF power and whether telemetry is enabled. How do you configure failsafe?

    November 14, 2017 at 3:02 pm #10457
    Stefan

    Hi Florent,

    missing failsafe settings is a issue of the last nightly versions. Please have a look at the PC-Software OpenTX Companion. There you can see and setup all the failsafe settings.

    Regards,
    Stefan

    November 14, 2017 at 4:37 pm #10461
    Florent Martel
    Keymaster

    Thanks for the tip!

    November 16, 2017 at 12:32 pm #10483
    Stefan
    Participant

    Dear Florent,
    yesterday I opened a issue in OpenTX with the missing failsafe-options for R9M. They have solved the problem immedeately and with the today version N436 we have the failsave settings back on the taranis.

    Regards,
    Stefan

You must be logged in to reply to this topic.

Topic Tags