• December 2, 2019 at 5:37 am #27130
    vyoufinder
    Participant

    Also, my gps will no longer lock., “compass not configured” and “check firmware or frame underscorec class” message has returned in Mission Planner.

    December 2, 2019 at 6:21 am #27138
    vyoufinder
    Participant

    Figured out the Pixhawk firmware problem introduced by install ardurover.apj then installing arducopter 3.6.11 and restoring saved params in Mission Planner.

    I figured it our only because it took me about 1.5 weeks last time I had to setup my Pixhawk , and the answer was to first flash an older firmware for arducopter onto the Pixhawk, then install the firmware I want (3.6.11), then do not use Mission Planner. I tried this process using Mission Planner and with no success. A developer from 3dr told me the Pixhawk was bricked and he suggesed to buy a new Pixhawk 4, but I did not listen and instead simply used QGround Control to start a fresh setup. Doing the setup in Qgroundcontrol, everything worked as normal. I just did this process, and at leas my Pixhawk is now back to where it was (actually a fresh install) before I started the FlightDeck process.

    Still not discovering the “cels” sensor though.

    December 2, 2019 at 7:46 am #27139
    vyoufinder
    Participant

    Update: Managed to get my Pixhawk configuration back. Re-installed the firmware on the Taranis again, then imported the model using Opentx2.3.2 and wrote the model to the Taranis.

    Now I show:

    1: GPS —
    2: Alt —
    3:VSpd —
    4: VFas —
    5: Cels * 0.00t..

    The Cels is now sort of working, but sort of half-blinking with another “t” and “[ ]” behind it flashing. Example: “0.00tt[]” and the “t[]” part is trying to blink, but never goes 100% off in between blinks.

    Any idea?

    December 2, 2019 at 7:58 am #27140
    vyoufinder
    Participant

    Another update: Created a new model from scratch, this time no sensors were listed on the telemetry page (page 13 of model setup.) Did the “discover new sensors” and this time I get:

    sensors value ID
    1: cels * 22.8V 225
    2: RSSI * 82dB 248
    3: RxBt * 5.1V 248

    So it seems I can get cels, RSSI, and RxBt or RSSI, RxBt, Alt, VSpd, VFas, and GPS.

    Does that mean anything? Also notice that RSSI and RxBt are both listed as ID 248.

    December 2, 2019 at 9:08 am #27141
    vyoufinder
    Participant

    Has this been tested with version 2.3.2? I see all the instructions and the SDCARD Contents I am instructed to download in the instructions is for OpenTX version 2.2

    Could this be my problem? I’m trying the old version listed in the instructions now.

    December 2, 2019 at 1:18 pm #27217
    Florent Martel
    Keymaster

    If you see the emulated “GPS” sensor updating, the FrSky telemetry link is working.

    If you see the emulated “Alt,” “VSpd,” and “VFAS” sensor updating, FlightDeck is working.
    As long as you’re using OpenTX 2.2 or later, FlightDeck will work…

    RxBt and RSSI come from your receiver itself.

    A “Cels” sensor should be discovered if there’s a working FLVSS or MLVSS on the SmartPort bus, regardless of the discovery of other sensors. In other words, if you’re having issues with your FLVSS sensor, it may be best to start troubleshooting by only having the FLVSS sensor connected to your receiver and attempting discovery (also connect the FLVSS sensor to the LiPo). You don’t need ArduPilot or FlightDeck for the FLVSS sensor to work properly.

    December 3, 2019 at 11:49 am #27229
    vyoufinder
    Participant

    Ok, thanks. I did a fresh firmware and re-installed using version 2.2.4, and for some reason, “cels” showed up without any trouble. I was then able to upgrade my bootloader and firmware to the most recent stable OpenTX and “cels” still works. Great. No idea why it would not work when I started with version 2.3.2, but at least that part works.

    However, I do not show any sensors and cannot seem to discover “Alt,” “VSpd,” or “VFAS” so I guess this means FlightDeck is not working on my setup? Any help on how to get these sensors to get discovered or what I could have configured wrong? I was able to get these before, what could be different now?

    December 3, 2019 at 12:28 pm #27230
    vyoufinder
    Participant

    Oops, I meant I do not see the sensors for Flightdeck you mentioned only: Alt, VSpd, VFAS. I do see GPS, RxBt, RSSI, and Cels.

    December 3, 2019 at 12:31 pm #27231
    Florent Martel
    Keymaster

    Since you see “GPS”, the FrSky telemetry link is working.

    In that case, there is a problem with the installation or execution of FlightDeck, so please verify those steps: proper installation and setup of OpenTX to start FlightDeck.

    December 4, 2019 at 1:49 am #27260
    vyoufinder
    Participant

    Thanks for telling me that it’s telemetry related, not receiver related. After much researching, I still have not isolated the problem and can’t seem to get any of the Flightdeck/telemetry info. coming out to the transmitter. Everything else is working very smoothly, and I’ve been through about all I can. I think there’s a good chance I burned up my (was brand new) telemetry cable in the process of troubleshooting. I was being smart trying to bind the receiver while connected and basically I ended up putting a 2 cell battery onto my receiver. Luckily, my zener diodes seem to have protected most everything, but the wires to them and the capacitors I had smoked as soon as I hooked it up and I disconnected of course as I jumped in fear.. I think I might’s seen smoke coming from the telemetry cable. It all happened so fast. I’ve ordered a spare and if I figure out otherwise, I’ll have the spare for if I ever do something like that again.

    December 4, 2019 at 4:22 am #27261
    vyoufinder
    Participant

    I’ve managed to figure it out. For some reason when I was using Companion, setting up my display page to use the script was not saving when I’d enter fltdck. Not sure why, could’ve been a 1D10T error on my part. Anyway, using the radion and checking it, it became obvious what the problem was and easily corrected it.

You must be logged in to reply to this topic.