• August 23, 2019 at 7:32 am #23666
    careinhardt
    Participant

    Will Flight Deck work on a Jumper T16 Transmitter using frsky telemetry receivers?

    August 23, 2019 at 11:32 am #23667
    Florent Martel
    Keymaster

    FlightDeck does not currently support the T16.

    August 28, 2019 at 9:14 am #23865
    Gerald McGivern
    Participant

    are there any plans to support the T16 ?

    August 28, 2019 at 4:24 pm #23880
    Florent Martel
    Keymaster

    Hi Gerald,

    Support for the X10, X10S, X12 and T16 is well underway but candidly no ETA since we’re focusing our attention right now on other projects. We will make an announcement in our newsletter once it comes out.

    August 28, 2019 at 10:20 pm #23915
    careinhardt
    Participant

    yaapu will work on the t16…

    August 29, 2019 at 10:26 am #23926
    Florent Martel
    Keymaster

    Yes, the yaapu script will work. Download link: https://discuss.ardupilot.org/t/an-open-source-frsky-telemetry-script-for-the-horus-x10-x12-and-taranis-x9d-x9e-and-qx7-radios/26443/832

    In fact, it’s the one pictured on the box of the T16.

    August 30, 2019 at 4:26 pm #23991
    jctpro
    Participant

    I am using the FrSky 40A Current sensor to read battery voltage and current use. Can I configure Flight Deck Telemetry page to show VFAS for the voltage?

    August 30, 2019 at 4:34 pm #23993
    Florent Martel
    Keymaster

    Not currently.

    It is assumed that some form of power module (voltage/current sensor) is always used on an ArduPilot compatible flight controller (non-FrSky), and as you know the information from the power module is what FlightDeck uses.

    This is intentional, as ArduPilot uses voltage/current information from that power module for several things, including failsafes, and FlightDeck is designed to provide feedback about the status of ArduPilot.

    Maybe there’s something about your configuration that would make a compelling case to allow a different voltage/current source. Let me know…

    December 1, 2019 at 11:43 am #27100
    vyoufinder
    Participant

    I’ve careflyy followed the instructions, and all has gone very smoothly until I got to discovering my FLVSS sensor. No “Cels” gets discovered. I also deleted all sensors and then had it discover new sensors, but it found the same ones I had before:

    1: VFAS 0.0V 1
    2: RSSI 85dB 248
    3:RxBt 5.1V 248
    4: Alt 0.0m 0
    5:VSpd 0.1m/s 0
    6: GPS 38º36″N109º32’W 251

    Tried it several times.. No “cell.” No “Cels.” I’ve also gone throug hthe instructions to make sure I’ve not missed anything, and I have not. Help?

    December 1, 2019 at 4:09 pm #27115
    vyoufinder
    Participant

    I’ve now tried resetting the Taranis to factory default, then flashing my firmware. When I do this, I only show 3 sensors now:

    RSSI, RxBT, and GPS.

    What is going on?

    December 1, 2019 at 6:40 pm #27116
    vyoufinder
    Participant

    Now I tried deleting the SD card, uninstalling OpenTX Companion 2.3.2, deleting all settings using the registry editor, then reinstalling. I did this maybe 4 times in all. Then I tried flashing the firmware again. This time, instead of following the instructions to use version 2.2, OpenTX Companion actually downloaded the correct version, “opentx-x9d+-lua-en-2.3.2.bin.. After I did this, Cels was listed, but showed no info. I tried to configure it, and when I did it configured it for all the models I added to the Taranis. I made some change (“te” was shown for one of the options, I clicked on “enter” to look at the different options, but then when I did “te” was no longer an option. So then I deleted all sensors and discovered all sensors again. This time Cels was not found, and deleted it from all my models on the Taranis.

    I guess I will delete the SD card again, flash the firmware again, reinstall Opentx Companion again, delete all references from the registry, all files from the c drive and AppData, and try again.

    Any answers?

    December 2, 2019 at 5:16 am #27126
    vyoufinder
    Participant

    I’m still trying to get this working after 3 days. I’ve tried several different firmware versions at this point on the Taranis, several different setup methods. Nothing I have done will make the Taranis find the FLVSS. I saw somewhere else in this forum that installing firmware for the pixhawk from a different model, then flashing back to arducopter and importing backed up parameters list fixed the problem. In my case, it just screwed it up more. Upon importing the params, I got “15 parameters missing” and were all related to battery voltage. IT did not make the sensors able ot be discovered, only screwed it up so now I get a constant “prearm check firmware or frame underscore class.”

    So now my Taranis is all screwd up, my Pixhawk all screwed up, and nothing working.

    December 2, 2019 at 5:23 am #27127
    vyoufinder
    Participant

    One weird thing that happened; when I flashed ardurover onto the Pixhawk, then booted, then shut down the copter, then installed arducopter 3.6.11 again, all sounds stopped on the s1000. I kept getting messages to check frame class, so tried installing arducopter again and importing params again. Now my motors are beeping again and messages to check frame class have stopped.

    December 2, 2019 at 5:28 am #27128
    vyoufinder
    Participant

    After re-flashing arducopter 3.6.11, and importing params exported just before firmware flashing on the Pixhaw, now my sensors are:

    RSSI 84dB
    RxBt 5.1v
    Alt: -.1m
    VSpd 0.0m/s
    VFAS 0.0V
    GPS 38xxxxxN109xxxw (working)

    Using various frimware combinations on the Pixhawk and Taranis yields different results. On some firmwares, I was able to get values other than 0.0 for VFAS and VSpd, but now I cannot.

    December 2, 2019 at 5:31 am #27129
    vyoufinder
    Participant

    I am also getting a new message: “check f s underscore t h r underscore value”

You must be logged in to reply to this topic.