• December 3, 2016 at 10:47 pm #3305
    Rolly

    Is FlightDeck3 compatible with PX4 Pro stack?

    December 4, 2016 at 3:46 pm #3310
    Florent Martel
    Keymaster

    Hi Rolly,

    FlightDeck is not currently compatible with the PX4 flight stack. Only ArduPilot is compatible.

    January 8, 2017 at 9:45 pm #3520
    Marvin Lange
    Participant

    are planning on making it compatible with PX4 PRO in the Future ?

    January 9, 2017 at 8:46 pm #3526
    Florent Martel
    Keymaster

    Hi Marvin,

    If there’s enough interest, we can work on the PX4 flight stack code.

    January 9, 2017 at 11:01 pm #3528
    Marvin Lange
    Participant

    Their is a huge group doing VTOL and Many are running Taranus. I will mention this Dicusion in the VTOL Forum to see if they will come over and express their interest. In my opinion its foolish not to have this if you are doing FPV Its a Redundent Data set if you loos your Mavlink transmission or reception

    January 10, 2017 at 3:18 am #3529
    Florent Martel
    Keymaster

    Thanks Marvin for your encouraging remarks. Can you provide me with a link to the forum (either here or to [email protected])? I would very much appreciate to be part of that discussion…

    February 1, 2017 at 3:53 am #3658
    Stefan

    Also interested in PX4 implementation!

    i am sure you will get much more customers when covering both flight stacks.

    February 1, 2017 at 10:04 am #3661
    Florent Martel
    Keymaster

    Hi Stefan,

    Thanks for the feedback. If anyone else would like PX4 flight stack support, please let us know…

    February 6, 2017 at 7:58 am #3679
    Philippe Boivin

    Hi,

    I’m using QGroundControl with PX4 so I would also like you to support PX4… and QGC 🙂
    I was about to purchase your script but I will wait.
    Thanks

    March 5, 2017 at 3:02 am #3872
    Arun

    Hi
    I am from India, I would also love to see this for the PX4.

    July 24, 2017 at 7:26 pm #6999
    H3xx
    Participant

    +1 for PX4 Compatibility

    February 28, 2018 at 5:08 am #11698
    kevin_hindyrickx
    Participant

    i also want PX4 suport

    March 16, 2018 at 3:46 pm #11855
    quentintin.d
    Participant

    Hello, I order FlightDeck with cable thinking it will be compatible for PX4 … but sadly not 🙁

    Do you plan to support it quickly ?

    March 19, 2018 at 5:34 pm #11872
    Thomas Lauzon
    Participant

    This is not currently one of our priority projects but it might become at some point.
    In the mean time, please let us know if you need a refund to your order. Email: [email protected]

    Thomas
    CT

    May 11, 2018 at 3:38 am #12169
    eric1
    Participant

    Hi Guys

    I’ve written firmware to convert Mavlink to Passthru, mostly to use on my LRS UHF /Taranis setup, but it should also work for PX4. If anyone is interested, the beta firmware is here: https://github.com/zs6buj/MavlinkToPassthru/wiki

    I use it on a Teensy 3.2 in the back of the Taranis to run passthru compatible LUA scrips and it’s working well for me, though it it’s still in beta.

    Right now my FlightDeck does not respond, as it seems to be looking for something I don’t know about. I assume your code is proprietary. It should be easy to solve and provide another option for FlightDeck users.

    Various Long Range solutions deliver Mavlink to the back of the Taranis. It would be nice if they could use FlightDeck too.

You must be logged in to reply to this topic.